Rails5 インストール時にeventmachineでハマる

Rails5 beta1が出たので試してみようと思い、インストール時に一箇所ハマりかけたので記録として残しておきます。

環境

ruby 2.2.4
bundler 1.11.2
Rails 5.0.0.beta1

あとは

% gem install rails --pre

でインストールを実行。この際にgemのエラーでインストールエラーになる。

ハマり方

ログ見れなくなっちゃったので忘れましたが eventmachineopenssl.h を読めませんよ的なエラー。

解決方法

eventmachine インストール時にコケるのでオプションつけてインストール

% gem install eventmachine -- --with-cppflags=-I/usr/local/opt/openssl/include

eventmachineのissueにもあがってました

これで再度Railsのインストールを実行

% gem install rails --pre

これで無事にインストールできました。